拉升在即狂牛选股公式及告成率回测数据

你的位置:【开元ky888棋牌手机版官方认证】 > 新品展示 > 拉升在即狂牛选股公式及告成率回测数据
拉升在即狂牛选股公式及告成率回测数据
发布日期:2022-09-07 08:44    点击次数:143

选股公式源码

VAR1:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

VAR5:=(HIGH+LOW+CLOSE)/3;

VAR6:=(VAR5-MA(VAR5,14))/(0.015*AVEDEV(VAR5,14));

VAR7:=(VAR5-MA(VAR5,89))/(0.015*AVEDEV(VAR5,89));

VAR8:=IF(VAR6>=150 AND VAR6<200 AND VAR7>=150 AND VAR7<200,10,0);

VAR9:=IF(VAR6<=-150 AND VAR6>-200 AND VAR7<=-150 AND VAR7>-200,-10,VAR8);

VAR21:=IF(VAR1>0,VAR1,0);

VARA:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

VARB:=100-ABS(VARA);

OX:=IF(VARB<90,VARB,100);

预警:=IF(VAR7>=200 AND VAR6>=150,15,IF(VAR7<=-200 AND VAR6<=-150,新品展示-15,VAR9))+60;

VAR2A:=VAR21>48 AND 预警>60 AND OX<100;

拉升在即狂牛:VAR2A AND COUNT(VAR2A,30)=1;

选股公式翻译

VAR1赋值:100*(开盘价-34日内开盘价的最低值)/(34日内最低价的最高值-34日内最自制的最低值)的5日俭朴移动匀称-20

VAR5赋值:(最低价+最自制+开盘价)/3

VAR6赋值:(VAR5-VAR5的14日俭朴移动匀称)/(0.015*VAR5的14日匀称绝对于偏向)

VAR7赋值:(VAR5-VAR5的89日俭朴移动匀称)/(0.015*VAR5的89日匀称绝对于偏向)

VAR8赋值:假定VAR6>=150ANDVAR6<200ANDVAR7>=150ANDVAR7<200,前去10,否则前去0

VAR9赋值:假定VAR6<=-150ANDVAR6>-200ANDVAR7<=-150ANDVAR7>-200,前去-10,否则前去VAR8

VAR21赋值:假定VAR1>0,前去VAR1,否则前去0

VARA赋值:(开盘价-开盘价的13日俭朴移动匀称)/开盘价的13日俭朴移动匀称*100

VARB赋值:100-VARA的绝对于值

OX赋值:假定VARB<90,前去VARB,否则前去100

预警赋值:假定VAR7>=200ANDVAR6>=150,前去15,否则前去假定VAR7<=-200ANDVAR6<=-150,前去-15,否则前去VAR9+60

VAR2A赋值:VAR21>48 AND 预警>60 AND OX<100

输出拉升在即狂牛:VAR2A AND 统计30日中餍足VAR2A的天数=1

条件选股:拉升在即狂牛[日线]告成率测试

测试股票数:4921

共收回旗子灯号:44739告成旗子灯号:25416失利旗子灯号:19017未实现旗子灯号:306

旗子灯号收回率:83.52%匀称告成率:57.20%告成率达到50%的股票数有:71.70%

利润1总匀称:17.34%最大匀称利润1:  151.65%  最小匀称利润1:  0.00%

利润2总匀称:1.11%最大匀称利润2:  110.22%  最小匀称利润2:  -45.22%

本站是供应集团知识打点的网络存储空间,全体内容均由用户宣布,不代表本站概念。请留心甄别内容中的联络要领、诱惑置办等信息,谨防诳骗。如缔造有害或侵权内容,请点击一键告发。

  • 上一篇:遇事不推,劳心而受益
  • 下一篇:没有了